Your Kindle may need updating or you could be blocked from the book store

According to techradar, all Amazon Kindle models bought before 2013 will need to be updated as you may soon be unable to download or purchase books from the book store.

These particular models require a new software update which is apparently needed to fix a critical issue. Amazon has requested that all affected users will need to install the new system before March 23, or their device will be blocked from the Kindle’s online services, such as the book store (this will also block you from downloading books that you have previously purchased from the store).

If you are registered as owning one of the older Kindle models, Amazon will have already contacted you to warn you of the requirements.

If users fail to update their device before March 23, they can expect to receive anerror message when they try to connect to the internet. Users will still be able to read books already on their device, however they will need to connect the Kindle to their PC via a USB connection in order to purchase or download others,

If you think movement could affect you, yet haven’t received a notification email from Amazon, it may be worth checking your junk email folder, or verify that the correct email is registered to the account.

Source: Techradar

Loading comments